Даунгрейд Perl модулей

Блог им. xoma 18 марта 2011 г., 13:46

История такова. Вчера днем решил обновить все Перловые модули, которые использует наше приложение. Обновление — дело то, как говорится, не хитрое. Запустил командочку и через пару десятков минут все было обновлено (ну кто же будет читать readme и changelog к каждому модулю =) ). Проверил функционирование приложения — все работает (тестов нет =( ), ура! Проблема всплыла только утром — некоторые крон-скрипты перестали запускаться. Проблема оказалась в модуле LWP, который 8 марта обновился до мажорной версии 6. Пришлось «откатить» LWP до предыдущей версии. Откат сделал путем «ручного» скачивания и установки модуля необходимой версии.

Какие еще существуют способы установки Perl модулей произвольной версии?

p.s. хорошо, что все эти обновления делались на тествой машинке =)



Комментарии 1

xoma
xoma
Спасибо за подсказку!
Пожалуйста, авторизуйтесь или зарегистрируйтесь для комментирования!